
 

 

Using GMG InkOptimizer in Prinergy 4  
 

New features in GMG Ruleset v3: 

 Easy to use – one click processing  

 Support for ColorServer / InkOptimizer 4.5 and 4.6 

 With version4.6: Detailed status messages in Prinergy   

 Trapping after Colormanagement  
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1 Introduction 
This manual describes how to integrate GMG ColorServer / InkOptimizer (version 4.5 or version 4.6) into a 
Kodak Prinergy 4 workflow with the help of Rules Based Automation (RBA). It shows the required Prinergy 
configuration, which will work for both GMG ColorServer and GMG InkOptimizer. In this example, we will use 
GMG InkOptimizer. 

Rules Based Automation allows for individually customized workflows and can be modified for your individual 
needs. This solution is just one example of how GMG ColorServer and GMG InkOptimizer can be integrated 
into a Prinergy workflow. Please adjust this solution to your needs.  

Even if the following solution was well tested, the use of RBA is out of scope of GMG products and services and 
GMG provides no warranties for the use of this solution. 

 

1.1 Requirements 

 GMG ColorServer/InkOptimizer needs to be installed on a computer with network access to/from Prinergy 
machine. At least one PDF-to-PDF hotfolder is required. 

 A Prinergy RBA license, which is an additional license and not part of the basic Prinergy application. 

 Basic knowledge about importing and modifying RBA rule sets. 

1.2 What is this Solution for?  

This solution will automate the file conversion with GMG InkOptimizer or GMG ColorServer from the Prinergy 
application. It allows to defining and starting a conversion in the Prinergy job manager. The conversion status of 
all pages will be displayed in both the list view and the thumbnail view. For each page, detailed warning or 
error messages are displayed directly in the Prinergy page list, allowing the operator to track the progress of 
each page from within the Prinergy user interface. 

 
List view 

 
Thumbnail view 
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2 Preparing the Network 
On the Prinergy server, create GMG ColorServer / InkOptimizer hotfolders and output folders. These hotfolders 
and output folders should be placed at the Prinergy Jobs volume in a “GMG” directory.  

Placing the hotfolders and output folders at the Prinergy server guarantees that Prinergy is able to access these 
hotfolders for file exchange. 

 

If you want to place the hotfolders and output folders at the GMG-PC instead of the Prinergy server, you have to 
make these folders accessible for the Prinergy server.  

The following steps are only necessary, if you place the hotfolders at the GMG-PC: 

1. On the GMG workstation, create a new Windows user named “Araxi” and provide administrator rights to 
this user. Use the same password that is defined for the Araxi user in Prinergy. 

Note:  “Araxi” is the default administrator name used by Prinergy. 

Note: You do not have to log on to the GMG computer as the “Araxi” user. This new user is only 
necessary to enable the access for Prinergy. Consult the “Prinergy Administrator Online Help”, 
chapter “About the Araxi service account” for additional information. 

2. On  the GMG computer, create a share for the directory that contains the GMG hotfolders and GMG 
output folders to the network. 

Note: Microsoft Windows is limited to a maximum of 10 concurrent connections to a share. If the 
share is used by other clients, Prinergy might be unable to connect to the share.  

3. On the Prinergy server, add the share in Prinergy Administrator:  

 From the Tools menu, select Configure System.  

 In the Configuration Options dialog box, click the Input Volumes tab.  

 Click Browse, browse to the shared folder, select it, and click OK.  

 Click Add Volume.  

 Click OK.  

Note:  Consult the “Prinergy Administrator Online Help”, chapter “Adding an input volume to 
Prinergy” for additional information. 
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3 Setting up GMG InkOptimizer 

3.1 Setting up GMG InkOptimizer Version 4.5 

1. On the Hotfolder menu, click New PDF to PDF Hotfolder. 
The PDF-to-PDF dialog box is displayed. 

2. Under Settings, click the [+] Button. 
The Input path dialog box is displayed.  

3. Under Basics, enter the path of the hotfolder that is located at the Prinergy Server. 

4. Select unlimited from the Recursive list. 

5. Select the option Create at the output side input folder structure. 

6. Confirm the settings with OK. 

 

7. In the navigation panel on the left, expand the PDF to PDF folder and click Output control. 

8. Under Name convention, select Output file name from input file.  

9. Select Overwrite existing files.  

 

Note:  Do not change the Prefix or Suffix value. Otherwise the rule set will not be able to detect the 
converted files. 

10. Configure all other hotfolder settings according to your needs.  

11. Click OK to save the hotfolder settings. 

12. Repeat all these steps for every hotfolder you want to use. 

 

How to activate PDF clean up 

 In the InkOptimizer main window, select Remove PDF to PDF jobs from the Hotfolder menu. 
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3.2 Setting up GMG InkOptimizer Version 4.6 

1. On the Hotfolder menu, click New PDF to PDF Hotfolder. 
The PDF-to-PDF dialog box is displayed. 

2. Under Files & Folders: Input Folders, click the Add Input Folders Button. 
The Input path dialog box is displayed.  

3. Under Path, enter the path of the hotfolder that is located at the Prinergy Server. 

4. Select unlimited from the Search Subfolders list. 

5. Select the option Use Same Folder Structure in Output Folder. 

 

6. Confirm the settings with OK. 
 

7. Switch to the Output Folders tab. 

8. In the Processed box, enter the path of the output folder that is located at the Prinergy Server. 

9. Select Keep File Name of Input File.  

10. Select Overwrite Existing Files.  

11. Under Cleanup & Backup, select Cleanup Method Delete  
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Note:  Do not add a Prefix or Suffix value. Otherwise the rule set will not be able to detect the 
converted files. 

12. Switch to the Errors & Warnings Tab 

13. Make sure that the Move Processed Files with Warning checkbox is not selected 

14. Make sure that the Move Unprocessed Error Jobs box is not selected. 

 

15. Switch to the Reports tab. 

16. Select the Create Reports checkbox. 

17. Make sure that the Report Transformations File box is empty. 

18. As Report Output Folder, select the same folder that was selected in step 8 as output folder. Report and 
PDF output file must be placed in the same folder. 

19. Select Auto-create from Input File Name.  

20. Change the suffix from “.html” to “.xml“. 

21. Select Overwrite Existing Files.  
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22. Configure all other hotfolder settings according to your needs.  

23. Click OK to save the hotfolder settings. 

24. Repeat all these steps 1 for every hotfolder you want to use. 

 

How to activate PDF clean up 

 In the InkOptimizer main window, select Remove PDF to PDF jobs from the Hotfolder menu. 
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4 Setting up the Custom Fields 
1. Start Prinergy Workshop and log on with your user ID and password. 

2. From the Tools menu, choose Custom Fields Manager. 

3. In the Custom Fields Manager dialog box, in the panel on the left side, select Page. 

4. Click the Add button. 

5. In the Add Custom Field dialog box, type „GMG-Status“ into the Name field. 

Note: Please use exactly the name GMG-Status and take care of spelling errors. Otherwise the rule set 
will not work.  

6. In the Type field, select Text. 

7. In the Show in Workshop field, select the check box.  

  

8. Click Close. 

9. View the new column and “GMG-Status” in the Pages pane. 
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5 Setting up a trapping template 
1. From the Tools menu, choose Process Template Editor. 

2. From the File menu, choose New Process Template. 

3. In the new Process Template, select the Trap checkbox. If you want to use thumbnails, select the 
Thumbnail checkbox. Expand the Trap option and set up your preferred trapping options.  

 

Note: Do not select additional checkboxes. Especially the ColorConvert checkbox must not be selected. 

4. Save the Template 
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6 Setting up the Prinergy Rule Sets 
This solution uses one copy of a rule set for each hotfolder. If you use, for example, three hotfolders in GMG 
InkOptimizer, you need three copies of this rule set. 

Importing the rule set 

1. Extract the GMG ruleset v3.zip file that you have received together with this manual. 

2. In Job Finder, from the Tools menu, select Rule Set Manager. 

Note: If you do not have full administrator user rights, (Read Only) is shown in the title bar of the Rule 
Set Manager window and all Rule Set Manager buttons are unavailable. If you have full 
administrator rights, all Rule Set Manager buttons will be available.  

3. In Rule Set Manager, in the Rule Set Library list, right-click on the root level Rule Sets folder and create a 
new group called GMG. 

4. Right-click on GMG and select Import. 

5. In the Import dialog box, select the GMG-Ruleset v3.xml file that you extracted from the GMG 
Ruleset v3.zip file in step 1. 

6. Click Import. 

Changing the rule set  

7. Double-click the imported rule set. 
The Rule Set Editor window opens. 

 

8. Double-click the connecting line between the Selected pages result and the GMG-Conversion – 
configure me action.  

 

9. In the Code Editor, in line 20, replace the magenta colored text enclosed by quotation marks in the figure 
above with the version of ColorServer / InkOptimizer that you are going to use. You can enter either 4.5 or 
4.6. 
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10. In the Code Editor, in line 23, replace the magenta colored text enclosed by quotation marks with the 
Hotfolder Name of the hotfolder that you want to use. This should be a short text that describes the 
hotfolder settings. 

11. In the Code Editor, in line 25, replace the magenta colored text enclosed by quotation marks with the path 
of the hotfolder that you want to use. 

12. In the Code Editor, in line 26, replace the magenta colored text enclosed by quotation marks with the path 
of the output folder that you want to use. 

13. In the Code Editor, in line 47, you can change the magenta colored number with the time out (in seconds) 
that you want to use. The default time out of  900 seconds (15 minutes) turned out to be a good average 
value, but you can increase  this if you are going to convert very many files at once. 

14. Click Save to close the Code Editor 

Note: Step 15 and 16 are required to configure the trapping after colormanagement. If you do not want to 
use trapping, you can delete the lower part of the rule (“Page Custom Field Changed” event plus all 
connected actions) 

15. Double-click the connecting line between Selected result for page is successful and the refine after 
colormanagement – configure me action.  

16. In the Process Template Path box, enter the trapping template you created in chapter 5 and click OK. 

 

Saving the rule set 

 Save the rule set and name it with the same name that you used as Hotfolder Name in step 10 and close 
the Rule Set Editor. 

Create additional Copies of the Rule for each GMG Hotfolder. 

 

7 Using the Rule Set 
1. Open the Job Manager. 

2. From the Tools menu, select Rule Set Manager. 

3. In the Rule Set Manager, enable all rule sets of the GMG group as system rules. 

4. Open or create a job in Prinergy and add some pages. 

5. From the View menu, select Visible Columns. 

6. Select GMG-Status and click OK. 

7. In the Pages view, select all pages that you want to convert and right-click to open the context menu. 
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8. From the context menu, select Manual Start Rules: System: GMG: <Name of the conversion>. 

 

9. If the Start Process box appears, click OK. 

 Now the GMG-Status custom field of every page will be updated and the files will be transferred to 
GMG InkOptimizer. 
 

 

10. After all processing files are converted or the timeout is reached, switch to the History view. If any errors 
should have occurred, an error message will show detailed information about these errors. 

11. Switch to the Thumbnail View. The status of each page is indicated by a colored frame around the 
thumbnail.  

Status in List view Color in Thumbnail view Comment 

Processing Blue  

Successful Green  

Successful with warning Orange Available with ColorServer / InkOptimizer 4.6 

Error Red  

 

Note: It might be necessary to refresh the view to see the changed thumbnails. 

 
 


